Welcome to MCList!

2 months agoJoined
Unable to connect to survival: Outdated client! Please use 1.20.2
2 months agoBungeeCordJoined
You have to accept the server resource pack in order to play! Visit http://s.moep.tv/rp for info on how to enable it!
2 months agoJoined
This server has mods that require FML/Forge to be installed on the client. Contact your server admin for more details.
2 months agoJoined
You are not whitelisted on this server!
2 months agoCrackedBungeeCordJoined
2 months agoJoined
This server requires you to install the Origins mod (v1.10.0) to play.